在Windows 7中安装sails时出错

安装sails时遇到了follwewing错误

> sails@0.11.0 preinstall E:\jb\npmtest\node_modules\sails > node ./lib/preinstall_npmcheck.js npm ERR! Windows_NT 6.1.7601 npm ERR! argv "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "sails" npm ERR! node v0.12.4 npm ERR! npm v2.10.1 npm ERR! file C:\Windows\system32\cmd.exe; npm ERR! path C:\Windows\system32\cmd.exe; npm ERR! code ELIFECYCLE npm ERR! errno ENOENT npm ERR! syscall spawn C:\Windows\system32\cmd.exe; npm ERR! sails@0.11.0 preinstall: `node ./lib/preinstall_npmcheck.js` npm ERR! spawn C:\Windows\system32\cmd.exe; ENOENT npm ERR! npm ERR! Failed at the sails@0.11.0 preinstall script 'node ./lib/preinstall_npmcheck.js'. npm ERR! This is most likely a problem with the sails package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! node ./lib/preinstall_npmcheck.js npm ERR! You can get their info via: npm ERR! npm owner ls sails npm ERR! There is likely additional logging output above. npm ERR! Please include the following file with any support request: npm ERR! E:\jb\npmtest\npm-debug.log 

我试图insatll风帆0.10我得到这个错误

 npm WARN deprecated grunt-lib-contrib@0.7.1: DEPRECATED. See readme: https://github.com/gruntjs/grunt-lib-contrib \ > ws@0.4.32 install E:\jb\npmtest\node_modules\sails\node_modules\socket.io\node_modules\socket.io-client\node_modules\ws > (node-gyp rebuild 2> builderror.log) || (exit 0) npm ERR! Windows_NT 6.1.7601 npm ERR! argv "C:\\nodejs\\\\node.exe" "C:\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "sails@0.10" npm ERR! node v0.12.4 npm ERR! npm v2.10.1 npm ERR! file C:\Windows\system32\cmd.exe; npm ERR! path C:\Windows\system32\cmd.exe; npm ERR! code ELIFECYCLE npm ERR! errno ENOENT npm ERR! syscall spawn C:\Windows\system32\cmd.exe; npm ERR! ws@0.4.32 install: `(node-gyp rebuild 2> builderror.log) || (exit 0)` npm ERR! spawn C:\Windows\system32\cmd.exe; ENOENT npm ERR! npm ERR! Failed at the ws@0.4.32 install script '(node-gyp rebuild 2> builderror.log) || (exit 0)'. npm ERR! This is most likely a problem with the ws package, npm ERR! not with npm itself. npm ERR! Tell the author that this fails on your system: npm ERR! (node-gyp rebuild 2> builderror.log) || (exit 0) npm ERR! You can get their info via: npm ERR! npm owner ls ws npm ERR! There is likely additional logging output above. 

我试图解决这个错误通过尝试npm cache clearbuild议通过此链接https://github.com/balderdashy/sails/issues/2751 。 但是我仍然得到错误。

Solutions Collecting From Web of "在Windows 7中安装sails时出错"