npm WARN弃用lodash@2.4.2:lodash @ <3.0.0不再维护

使用npm全局安装grunt-cli时出现错误。 这与lodash有关:

npm WARN deprecated lodash@2.4.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^3.0.0. 

以下是我正在使用的版本以及安装的全局软件包列表。

节点: v5.1.0

npm: v3.5.0

npm list -g: http : //pastebin.com/NuJU3bY0


我试图在全球范围内安装最新版本的lodash(v3.10.1),但卸载grunt-cli全局程序包后又重新出现错误,然后重新安装全局程序包。 以下是安装日志:

 sudo npm install lodash -g /usr/local/lib └── lodash@3.10.1 sudo npm install grunt-cli -g npm WARN deprecated lodash@2.4.2: lodash@<3.0.0 is no longer maintained. Upgrade to lodash@^3.0.0. /usr/local/bin/grunt -> /usr/local/lib/node_modules/grunt-cli/bin/grunt /usr/local/lib └─┬ grunt-cli@0.1.13 ├─┬ findup-sync@0.1.3 │ ├─┬ glob@3.2.11 │ │ ├── inherits@2.0.1 │ │ └─┬ minimatch@0.3.0 │ │ ├── lru-cache@2.7.3 │ │ └── sigmund@1.0.1 │ └── lodash@2.4.2 ├─┬ nopt@1.0.10 │ └── abbrev@1.0.7 └── resolve@0.3.1 npm WARN In grunt-cli@0.1.13 replacing bundled version of nopt with nopt@1.0.10 npm WARN In grunt-cli@0.1.13 replacing bundled version of findup-sync with findup-sync@0.1.3 npm WARN In grunt-cli@0.1.13 replacing bundled version of resolve with resolve@0.3.1 npm WARN In grunt-cli@0.1.13 replacing bundled version of lodash with lodash@2.4.2 npm WARN In grunt-cli@0.1.13 replacing bundled version of glob with glob@3.2.11 npm WARN In grunt-cli@0.1.13 replacing bundled version of inherits with inherits@2.0.1 npm WARN In grunt-cli@0.1.13 replacing bundled version of minimatch with minimatch@0.3.0 npm WARN In grunt-cli@0.1.13 replacing bundled version of sigmund with sigmund@1.0.1 npm WARN In grunt-cli@0.1.13 replacing bundled version of lru-cache with lru-cache@2.7.3 npm WARN In grunt-cli@0.1.13 replacing bundled version of abbrev with abbrev@1.0.7 

任何人都可以告诉我我做错了什么,或者如何解决这个错误,并得到一个干净的安装grunt-cli?

Solutions Collecting From Web of "npm WARN弃用lodash@2.4.2:lodash @ <3.0.0不再维护"

grunt-cli包依赖于lodash的旧版本。 它不应该影响咕噜声的function; 这只是一个警告信息。

所以,你没有做错任何事情,这不是一个错误信息,只是一个警告,你已经安装了grunt-cli的方式应该可以正常工作。

您可以尝试在控制台中运行此命令:

 npm i -g lodash 

让我知道这是否修复它。