在Mac上安装Ionic Framework的错误

当试图通过node.js使用命令$ npm install -g cordova ionic在我的mac上安装ionic framework时我收到以下错误

 npm ERR! Darwin 14.3.0 npm ERR! argv "node" "/usr/local/bin/npm" "install" "-g" "cordova" "ionic" npm ERR! node v0.12.5 npm ERR! npm v2.12.0 npm ERR! Attempt to unlock /usr/local/lib/node_modules/cordova, which hasn't been locked npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> npm ERR! Darwin 14.3.0 npm ERR! argv "node" "/usr/local/bin/npm" "install" "-g" "cordova" "ionic" npm ERR! node v0.12.5 npm ERR! npm v2.12.0 npm ERR! Attempt to unlock /usr/local/lib/node_modules/ionic, which hasn't been locked npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> npm ERR! Please include the following file with any support request: npm ERR! /Users/kernelliott/npm-debug.log 

任何想法,为什么我得到这些错误?

Solutions Collecting From Web of "在Mac上安装Ionic Framework的错误"