错误:运行“bower install”时找不到模块“js-yaml”

我正在通过AngularJS应用程序的基本设置(刚入门),目前正在尝试为应用程序安装Bower组件。

当我从terminal运行bower install ,出现以下错误:

 Error: Cannot find module 'js-yaml' at Function.Module._resolveFilename (module.js:337:15) at Function.Module._load (module.js:287:25) at Module.require (module.js:366:17) at require (module.js:385:17) at Object.<anonymous> (Path\bower\node_modules\configstore\index.js:9:12) at Module._compile (module.js:425:26) at Object.Module._extensions..js (module.js:432:10) at Module.load (module.js:356:32) at Function.Module._load (module.js:311:12) at Module.require (module.js:366:17) at require (module.js:385:17) 

我没有在我的脚本中的任何地方指定js-yaml模块(据我所知),所以不知道这个依赖来自哪里。

我已经尝试删除node_modules文件夹,清除npmcaching,包括package.json文件中的js-yaml ,然后重新运行npm install,但运行bower install时出现同样的错误

如果有帮助,我的bower.jsonpackage.json文件如下所示:

Bower.json

 { "name": "starter-node-angular", "version": "1.0.0", "dependencies": { "bootstrap": "latest", "font-awesome": "latest", "animate.css": "latest", "angular": "latest", "angular-route": "latest" } } 

的package.json

 { "name": "starter-node-angular", "main": "server.js", "dependencies": { "express" : "~4.5.1", "mongoose" : "~3.8.0", "body-parser" : "~1.4.2", "method-override" : "~2.0.2", "js-yaml" : "latest" } } 

我正在使用WebStorm 10.0.4(空项目作为起点)。

有没有人遇到这个或类似的问题,可能指向我如何解决这个问题的正确方向?

Solutions Collecting From Web of "错误:运行“bower install”时找不到模块“js-yaml”"

首先运行sudo npm install -g js-yaml应该让你朝正确的方向发展。

我的猜测是,它不涉及你的应用程序,但凉亭是打破了。 尝试重新安装它:

 $ npm uninstall bower 

然后像这样重新安装它:

 $ npm install -g bower 

这为我解决了。